05 May 2010

evilvte 0.2.7 released

calebjoined: 2007-09-22
posted: 570
promoted: 108
bookmarked: 84
1subject: evilvte 0.2.7 released
2008-03-18
  
Changelog:
 * Support SHOW_BUILDTIME_OPTION
 * Add a script "showvte" to show buildtime configuration
 * Show configuration status in configure script
 * Simplify src/config.h
swyearjoined: 2007-10-04
posted: 50
promoted: 1
bookmarked: 0
2subject: 如何 debug
2008-03-18
  
openSUSE 10.3 kde 莫名其妙就當掉
只留下程式記憶體區段錯誤 
swyearjoined: 2007-10-04
posted: 50
promoted: 1
bookmarked: 0
4subject:
2008-03-18
  
沒有更改任何 config.h
evilvte.spec
 Name:           evilvte
Version:        0.2.7
Release:        1
License:        GPL v2 or later
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
BuildRequires:  vte-devel pkgconfig
%if %suse_version <= 1000
BuildRequires: xorg-x11-devel glib2-devel gtk2-devel
%endif
Requires: vte
Source0: %{name}-%{version}.tar.gz
Source1: evilvte.desktop
Group:          System/Terminals
Summary:        VTE based, super lightweight terminal emulator

%description
VTE based, super lightweight terminal emulator

%prep
%setup
%build
./configure --prefix=/usr
make

%install
DESTDIR=$RPM_BUILD_ROOT make install
mkdir -p $RPM_BUILD_ROOT/usr/share/applications/
install -m 644 $RPM_SOURCE_DIR/evilvte.desktop $RPM_BUILD_ROOT/usr/share/applications/
%clean
rm -rf "$RPM_BUILD_ROOT"

%files
%defattr(-,root,root)
%doc Changelog COPYING
%_bindir/evilvte
%_bindir/showvte
%_datadir/pixmaps/evilvte.*
%_datadir/applications/evilvte.desktop
%_mandir/man1/evilvte.1.gz
發現只要將滑鼠指到 Tab 那一行
就會當(屢試不爽)
vte-0.16.9-4
edited: 1 
swyearjoined: 2007-10-04
posted: 50
promoted: 1
bookmarked: 0
6subject:
2008-03-19
  
對不起...因為在0.2.2 就會當...
本來想等幾個版本再看看會不會改善... 
calebjoined: 2007-09-22
posted: 570
promoted: 108
bookmarked: 84
7subject:
2008-03-20
  
swyear
對不起...因為在0.2.2 就會當... (Excuse me, I forgot to say that 0.2.2 also crashes.)
本來想等幾個版本再看看會不會改善... (I thought newer versions maybe have fixed the problem.)

0.2.9 修正了一個 GTK+ 的 notebook bug
請下載 0.2.9 然後設定
#define TAB_MOUSE_SCROLLABLE FALSE
「或許」可以解決你的問題…
evilvte 0.2.9 fixed an GTK+ notebook bug.
Please download evilvte 0.2.9 and set
#define TAB_MOUSE_SCROLLABLE FALSE
It "maybe" can solve your problem. 
swyearjoined: 2007-10-04
posted: 50
promoted: 1
bookmarked: 0
8subject:
2008-03-22
  
caleb

#define TAB_MOUSE_SCROLLABLE FALSE
It "maybe" can solve your problem.

給您回報一下
在 0.3.0 測試,仍然無效
照當不誤

// #define TAB_MOUSE_SCROLLABLE TRUE
改成
#define TABBAR_MOUSE_SCROLLABLE FALSE
是這樣吧! 
swyearjoined: 2007-10-04
posted: 50
promoted: 1
bookmarked: 0
12subject:
2008-03-23
  
可以了
太感激
因為現在正測試 11.0 alpha3
konsole 是壞的、lilyterm 會躲、原本的 evilvte 又要小心滑鼠絕不能移過去
結果用一個醜醜的 xterm
您可以從
 http://download.opensuse.org/repositories/home:/swyear/openSUSE_10.3/
安裝看看
再次感謝 

No comments:

Post a Comment