23 December 2010

[WORKAROUND] build failure with GTK+ 2.91.7

Prepared for GTK+ 3.0, the latest release of GTK+ 2.9x has changed its soname.

Some compilers do not accept "-Wl,--as-needed" or similar options, so I use a minimal set of linking options, which can not find new soname automatically.

If you want to build current evilvte with GTK+ 2.91.7, please set your LDLIBS environment variable.

For example:
export LDLIBS=`pkg-config --libs vte-2.90`

Thus everything will be fine.

No comments:

Post a Comment