11 February 2011

[WORKAROUND] build failure with GTK+ 3.0.0

GTK+ 3.0.0 has been released. It has changed its soname again.

Some compilers do not accept "-Wl,--as-needed" or similar options, so I use a minimal set of linking options, which can not find new soname automatically.

If you want to build current evilvte with GTK+ 3.0.0, please set your LDLIBS environment variable.

For example:
export LDLIBS=`pkg-config --libs vte-2.90`

Thus everything will be fine.

I will fix this problem in next release, of course. :-)

No comments:

Post a Comment